Timetracker Cloud Service Outages

Incident Report for Everit

Update

We identified the root cause and working together with Atlassian team to resolve it as soon as we can.
Posted Jan 08, 2026 - 11:01 CET

Identified

We are currently investigating a service issue affecting a subset of customers. Some users have experienced performance degradation and brief periods of limited availability.

Our team is already identified the underlying causes and working on a permanent solution. The Global Permissions lookup on the Atlassian Jira side intermittently times out. As a result, requests that rely on this permission check become queued and cannot be processed in time, leading to delayed or failed responses for users. As a mitigation, we will refactor our permission-checking logic to avoid this dependency and prevent similar request backlogs in the future.

We apologize for the inconvenience and appreciate your patience while we work toward a permanent resolution.
Posted Dec 19, 2025 - 13:10 CET
This incident affects: Timetracker - Time Tracking & Reporting.