Timetracker Cloud is not available
Incident Report for Everit
Postmortem

Incident description

The “Timetracking in Issue Glance” feature preloaded its state when a Jira issue is opened in the browser. It caused a heavy load when the users open multiple Jira issues in multiple browser tabs at the same time. This load consumed a lot of disk space on our servers (incident 2022.04.01.).

After fixing this preloading behaviour we installed a new version of the Timetracker application on 2022.04.04. During this installation a deadlock was caused by the old opened browser tabs.

Timeline (UTC)

incidend #1 
2022.04.01. 14:21 
- First monitoring alert received. 
- Our technical team started to investigate the alert. 
- One of our host machine run out of disk space because of a heavy load. 
2022.04.01. 16:05 - The disk volumes were increased. 
- The Timetracker application was availble again. 

incident #2 
2022.04.04. 08:49 
- The new Timetracker version was installed. 
- The old clients (the opened browser tabs) still put our backend under pressure. 
- This caused a deadlock in our database.

Impact

The clients couldn't use the Timetracker application in these time windows.

There were no data loss during the outage.

Posted Apr 07, 2022 - 16:48 CEST

Resolved
This incident has been resolved.
Posted Apr 04, 2022 - 11:51 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 04, 2022 - 11:30 CEST
Monitoring
A fix has been implemented and we are monitoring the result.
Posted Apr 04, 2022 - 11:29 CEST
Investigating
Timetracker Cloud is down after a deployment. We are currently investigating this issue.
Posted Apr 04, 2022 - 10:56 CEST
This incident affected: Timetracker - Time Tracking & Reporting.