Investigating Timetracker Cloud Performance Degradation

Incident Report for Everit

Monitoring

we carried out a short maintenance window (5–15 minutes) to upgrade the underlying environment. The machine received additional resources, including increased CPU and memory. We expect this to improve performance, and we will continue to monitor the system closely. Further improvements are still in progress, and we appreciate your patience.
Posted Nov 24, 2025 - 14:27 CET

Identified

We have applied several adjustments and fixes designed to improve the application's performance.

We continue to investigate the underlying root causes and will implement additional application-level and system-level improvements as our analysis progresses.
Posted Nov 21, 2025 - 15:54 CET

Investigating

We are currently investigating a service issue affecting a subset of customers. Since Sunday, some users have experienced performance degradation and brief periods of limited availability.

Our team is actively working to identify the underlying causes and is continuously monitoring system performance to stabilize the service. We will continue dedicated efforts in the coming days to improve overall responsiveness and restore full availability.

We apologize for the inconvenience and appreciate your patience while we work toward a permanent resolution.
Posted Nov 20, 2025 - 11:35 CET
This incident affects: Timetracker - Time Tracking & Reporting.